Kedy má EIGRP Hello časovač 5 a kedy 60 sekúnd?

január 25, 2011 by

Zdá sa, že niektorým ľuďom EIGRP časovače nemôžu dať spať. Kolega vám v tomto článku napísal, kde máte časovače hľadať a teraz vyvstáva otázka, kedy je hello 5 a kedy 60 sekúnd. Najskôr teória, potom prax.

Teória

Hello protokol je určený na objavovanie, vytváranie a udržiavanie susedstiev v protokole EIGRP.

Odosiela sa každých 5 sekúnd na:

  • broadcast media (napr. Ethernet)
  • point-to-point serial linkách (napr. PPP, HDLC)
  • multipoint circuits s rýchlosťou väčšou ako T1 – 1.544 Mbps (napr. Frame Relay)

Odosiela sa každých 60 sekúnd na:

  • multipoint circuits s rýchlosťou menšou alebo rovnou ako T1 – 1.544 Mbps (napr. Frame Relay)

Hold-down časovač je nastavený na trojnásobok hello. Narozdiel od protokolu OSPF sa časovače hello a hold-down nemusia na susedoch zhodovať, aby sa susedstvo vytvorilo.

Prax

Tak a teraz sa na to podívajme prakticky. Budem používať Frame Relay konfiguráciu, aby som ukázal rôzne kombinácie. Zapojím topológiu podľa obrázka. To čudo v strede je Frame Relay Switch (FRS). Ak neviete čo to je, tak nič to, proste krabička. Do krabičky nastavím mapovanie portov na tzv. DLCI – 1:102, 2:201. Teraz dokáže krabička pakety prepínať.

Topológia Frame RelayObrázok č. 1: Topológia Frame Relay

Routre nakonfigurujem s minimálnou konfiguráciou pre serial interfejs 0/0 na oboch smerovačoch. Pri Frame Relay ide o multipoint typ siete, presnejšie Non-Broadcast Multiple Access (NBMA).

R1(config)# interface Serial0/0
R1(config-if)# ip address 192.168.0.1 255.255.255.0
R1(config-if)# encapsulation frame-relay
R1(config-if)# frame-relay interface-dlci 102

R2(config)# interface Serial0/0
R2(config-if)# ip address 192.168.0.2 255.255.255.0
R2(config-if)# encapsulation frame-relay
R2(config-if)# frame-relay interface-dlci 201

EIGRP nakonfigurujem na oboch smerovačoch ako:

R1(config)# router eigrp 1
R1(config-router)# network 192.168.0.0

Smerovač R1 dokáže pingnúť 192.168.0.2 ale nedokáže pingnuť samého seba. To je v poriadku pri takto postavenej konfigurácii. Treba chvíľu čakať (vcelku dosť) a EIGRP susedstvo sa vytvorí. Pri nasledujúcom výpise si overíme správnosť časovačov.

R1# show ip eigrp interfaces detail 
IP-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0         8       0/15          50           0
  Hello interval is 60 sec
  Next xmit serial <none>
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 1/3
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0
  Retransmissions sent: 1  Out-of-sequence rcvd: 0
  Authentication mode is not set

Hello je nastavený na 60 sekúnd a časovač hold-down na 180 sekúnd, pretože ide o Frame Relay konfiguráciu, čo je multipoint typ siete. Keďže nebol použitý príkaz bandwidth, ktorý oznamuje smerovaciemu protokolu prenosovú rýchlosť interfejsu, tak sa linka pokladá za T1 (1544 kbps), čo je pomalá linka a preto sa aplikuje 60 sekundový hello časovač. Pozor, príkaz bandwidth len oznamuje smerovacím prokotolom prenosovú rýchlosť linky, ktorú nastaví administrátor. Skutočná fyzická prenosová rýchlosť sa konfiguruje príkazom clock rate. Podľa správnosti by bandwidth mal kopírovať hodnotu clock rate, ale nemusí tomu vždy byť tak.

Nastavme iný bandwidth, napr. na 2048 kbps:

R1(config-if)# bandwidth 2048

Pozrime si výpis:

R1# show ip eigrp interfaces detail 
IP-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0         8       0/11          50           0
  Hello interval is 5 sec
  Next xmit serial <none>
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 1/3
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0
  Retransmissions sent: 1  Out-of-sequence rcvd: 0
  Authentication mode is not set

Zmenu môžeme vidieť aj na routri R2 výpisom:

R2# show ip eigrp neighbors 
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.0.1             Se0/0             14 00:08:33    1  5000  0  6

Linka sa zrazu pokladá za rýchlu linku na multipoint sieti, čiže sa aplikuje 5 sekundový hello časovač. Samozrejme, na routri R2 sú časovače stále nastavené na 60/180 sekúnd a teda pri výpise show ip eigrp neighbors na R1 uvidíme hold-down časovač v rozpätí 120-180 sekúnd.

V podstate ponechám Frame Relay konfiguráciu, len namiesto fyzických interfejsov použijem subinterfejsy typu point-to-point. Z fyzického interfejsu zmažem IP adresu a vytvorím nový subinterfejs. Do neho vložím IP adresu a DLCI.

R1(config)# interface Serial0/0
R1(config-if)# no ip address

R1(config)# interface Serial0/0.1 point-to-point
R1(config-subif)# ip address 192.168.0.1 255.255.255.0
R1(config-subif)# frame-relay interface-dlci 102

R2(config)# interface Serial0/0
R2(config-if)# no ip address

R2(config)# interface Serial0/0.1 point-to-point
R2(config-subif)# ip address 192.168.0.2 255.255.255.0
R2(config-subif)# frame-relay interface-dlci 201

Výpisy show ip eigrp interfaces detail a show ip eigrp neighbors hovoria jasnou rečou, časovače sú nastavené na 5/15 sekúnd. Natvrdo sme povedali, že síce ide o Frame Relay konfiguráciu, ale konfigurácia je na point-to-point linkách, čiže sa aplikujú časovače platné pre point-to-point linky.

Skúsme ešte zmeniť konfiguráciu na nový subinterface typu multipoint. Keď sa raz nakonfiguruje subinterfejs nejakého typu, už je dosť problém zmeniť jeho typ v niektorých IOS, takže radšej spravím nový subinterfejs a starý zmažem.

R1(config)# no interface Serial0/0.1
R1(config)# interface Serial0/0.2 multipoint
R1(config-subif)# ip address 192.168.0.1 255.255.255.0
R1(config-subif)# frame-relay interface-dlci 102

R2(config)# no interface Serial0/0.1
R2(config)# interface Serial0/0.2 multipoint
R2(config-subif)# ip address 192.168.0.2 255.255.255.0
R2(config-subif)# frame-relay interface-dlci 201

Po niekoľko minútovom čakaní sa konfigurácia rozbehla a výsledok je totožný s prvým prípadom. Teraz som natvrdo povedal, že ide o multipoint serial linky na multipoint Frame Relay sieti. Ak zmením bandwidth na hodnotu vyššiu ako 1544 kbps, tak sa zmenia implicitné časovače z 60/180 na 5/15.

A nezabúdajme na možnosť meniť časovače aj manuálne konfiguráciou pod interfejsom:

R1(config-if)# ip hello-interval eigrp 1 <1-65535>
R1(config-if)# ip hold-time eigrp 1 <1-65535>

Viac o Frame Relay je na CCNA4 a konfigurácia EIGRP na Frame Relay sieti je v CCNP Route.

Filip Burda

Reklamy

Webinár o IPv6

január 22, 2011 by

Druhý zo série Webinárov sa uskutoční budúci týždeň v utorok, 25.1.2011 o 17:00hod (trvanie asi 1,5hod., vrátane diskusie účastníkov).

Prednášať bude Peter Feciľak, RCNA TU Košice, na tému: IPv6 svet.
Pôjde o VoIP only webinár (zvuk sa prenáša prostredníctvom mikrofónu a slúchadiel/reproduktora na počítači).

Ako sa zúčastniť (Prihlásiť sa je potrebné aspoň 5 minút pred začiatkom meetingu):
Cislo meetingu: 203 887 117

1. Kliknite na:
https://cisco.webex.com/ciscosales/j.php?ED=157712307&UID=0&PW=NNzVhYTA5Mzk1&RT=MiMyNQ%3D%3D
2. Zadajte svoje meno a email.
3. Heslo: 123

 

Záznam z predošlého webinára o STP je na adrese:
https://cisco.webex.com/ciscosales/lsr.php?AT=pb&SP=MC&rID=48926922&rKey=b986bbba1eadc48f

Zdroj: inetacad.net

NAG 2011

január 19, 2011 by

Súťaž NAG 2011 je tu! Príď si preveriť svoje sieťarske vedomosti a ak budeš úspešný, postúpiš do národného kola. Viac o školskom kole súťaže, ktoré sa koná 18.2.2011, sa dozvieš na stránke:

https://ciscoblogfiit.wordpress.com/nag-2011/

IOS tipy a triky

január 17, 2011 by

V tomto príspevku by som rád ukázal zopár trikov v IOS, ktoré sa vám môžu zísť. Pôjde o príkazy do, alias, vloženie otáznika do textu, filtrovanie výpisu a zresetovanie konfigurácie.

Príkaz do

Ak si chceme zobraziť napríklad smerovaciu tabuľku, alebo hocaký iný príkaz z kategórie exec príkazov, no nie sme v privilegovanom režime, neostáva nám nič iné, ako napísať príkaz end, alebo stlačiť príslušnú klávesovú skratku. Ak však nechceme odísť z príslušného režimu, môžeme si pomôcť príkazom do. Ak si teda chceme zobraziť smerovaciu tabuľku a konfigurujeme, čo ja viem, protokol RIP, tak napíšeme nasledovné:

Router(config-router)#do show ip route

Problém je, že akonáhle napíšeme príkaz do, otáznik ani tabulátor nám nie a nie pomôcť. Musíme teda príkaz napísať správne aj bez ich pomoci. Príkazy sa dajú písať aj skratkovito, napr. „do sh ip ro“. Tento príkaz nie je v starších verziách IOS.

Príkaz alias

show ip interface brief. Dlhý príkaz, skúsme si to skrátiť: sh ip int brie. Stále veľa na môj vkus. Tak si nahraďme celý tento príkaz nejakým aliasom. Alias vytvorí pre definovaný príkaz nový názov, ktorý bude IOS poznať a budeme ho môcť použiť. Syntax je nasledovná:

Router(config)#alias <režim alebo skupina príkazov> <alias> <príkaz>

Keďže show príkazy sú z kategórie exec príkazov a celý ten show príkaz chcem nahradiť aliasom „s“, tak použijem:

Router(config)#alias exec s sh ip int brie

Ako vidíte, <príkaz> som si mohol skrátiť a nevypisovať celý názov, keďže to je jedno-jednoznačný názov. Teraz môžem začať používať môj nový príkaz „s“.

Router#s
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down

A schválne si pozrime, čo nám zobrazí otáznik:

Router#s?
*s="sh ip int brie"  sdlc     send  set
setup                show     slip  snasw
spec-file            squeeze  ssh   start-chat
systat

Pribudol mi nový príkaz *s=”sh ip int brie”. Tento príkaz môžeme použiť z hocijakého režimu príkazom: „do s“.

Mimochodom, IOS má v sebe už niekoľko preddefinovaných aliasov a to:

  • p – ping
  • h – help
  • lo – logout
  • u alebo un – undebug
  • w – where

Vloženie znaku „?“

Funkcia otáznička je nám jasná, no čo ak chcem vložiť otáznik priamo do textu? Nech už to je akýkoľvek popisok (description, banner…) alebo aj konfiguračný príkaz (destination-pattern 1..[.]?[.]?), tak použijem buď klávesovú skratku [Ctrl+V] a za tým napíšem otáznik, alebo stlačím klávesy [ESC+Q] naraz alebo po sebe. Po stlačení kláves sa nič nestane, akurát, že keď stlačím teraz „?“, tak sa mi otáznik naozaj objaví v texte. Takže MOTD banner môžem napísať takto:

Router(config)#banner motd %Co tu hladas[Ctrl+V]?%

A ako banner sa nám bude zobrazovať:

Co tu hladas?

Filtrovanie výpisu

Niekedy sú výpisy až príliš dlhé a my hľadáme len jeden konkrétny riadok, alebo výpisy s nejakou spoločnou vlastnosťou. Ak nemáte chuť lúskať celý výpis, tak si ho môžete odfiltrovať. Filtrovať sa dá prakticky čokoľvek, stačí, že je povolená pajpa (lomená čiara „|“) za príkazom. Napríklad si chcem nechať vyfiltrovať moje priamo pripojené interfejsy v stave down. Použijem príkaz:

Router#show ip interface brief | i down

Za pajpou dávame kľúčové slovo, ktoré definuje typ filtrovania. Kľúčových slov je viac, no ukážem len základné a to:

  • begin – Zobraz výpis od prvého riadku, ktorý matchuje, až do konca výpisu
  • exclude – Odstráň všetky riadky ktoré matchujú
  • include – Zobraz len tie riadky, ktoré matchujú
  • section – Zobraz len sekciu (súvislý blok) výpisu, ktorej prvý riadok matchuje
  • format – Zobraz výstup vo formáte XML

a za kľúčovým slovom dáme výraz, ktorý sa má matchnúť. Ja som použil include, ale skrátil som si to na „i“.

Ak si chcem pozrieť zo show run výpis interfejsu F0/0, musím zadať nasledovné:

Router#show run | b FastEthernet0/0

Žiadne skratky a ešte je to aj case sensitive! Samozrejme, tento výpis mi zobrazí show run počnúc riadkom interface FastEthernet0/0 do konca. S použitím príkazu section to bude vyzerať nasledovne:

Router#show run | s FastEthernet0/0
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
 !

Treba si len dávať pozor pri zadávaní výrazu na filtrovanie, lebo sa zadáva v tvare regulárneho výrazu. Podívajme sa na nasledovný výpis:

Router#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, FastEthernet0/0
L        192.168.0.1/32 is directly connected, FastEthernet0/0

Nakonfiguroval som len interfejs F0/0, ale mám nový IOS a ten zobrazuje okrem priamo pripojenej cesty (C) aj IP adresu samotného interfejsu ako /32 (L). Ak zadám ako filter:

Router#show ip route | i 0.0
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, FastEthernet0/0
L        192.168.0.1/32 is directly connected, FastEthernet0/0

tak mi vypísalo aj L riadok. Prečo? Veď tam nie je nikde výraz „0.0“. Akurát, že v regulárnych výrazoch bodka reprezentuje (skoro) hocaký znak. Čiže mi tu matchuje nielen „0.0“ ako časť adresy siete, ale aj „0/0“ na konci riadku. Bodka musí byť escapnutá spätným lomítkom „\“. Teraz už bude výpis vyzerať takto:

Router#show ip route | i 0\.0
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, FastEthernet0/0

Defaultná konfigurácia

Už ste asi niečo podobné zažili. Konfigurovali ste interfejs a keď ste mali konfig hotový, tak ste zistili, že to bol nesprávny interfejs. Aj tu je ľahká pomoc ako vrátiť veci do pôvodného stavu. Interfejs a prakticky čokoľvek iné, môžeme zresetovať do defaultného stavu príkazom default. Keďže ale konfiguráciu mám hotovú a správnu, tak pôjdem na to inteligentne. Najskôr si zobrazím, čo som nakonfiguroval:

Router#show run | s interface FastEthernet0/0
 interface FastEthernet0/0
 description TEXT
 ip address 192.168.0.1 255.255.255.0
 speed 100
 full-duplex
 !

Skopírujem si tento výpis, napr. do notepadu. Teraz zresetujem interfejs F0/0 do defaultného stavu príkazom:

Router(config)#default interface f0/0

Krátko na to uvidím ďalšie riadky výpisu:

Building configuration...

Interface FastEthernet0/0 set to default configuration

No a teraz sa posuniem do správneho interfejsu a len nakopírujem konfig z notepadu.

A teraz si už len pamätať tieto triky a používať ich 🙂

Filip Burda

Hľadáte hodnoty EIGRP timer-ov?

január 11, 2011 by

Zdravím Vás kolegovia.

Veľmi často sa v teórii na našich CCNA kurzoch stretávate s nutnosťou zistiť alebo overiť hodnoty časovačov alebo “timerov” v smerovacích protokoloch. RIP a OSPF problémové nie sú, EIGRP na druhej strane má niekoľko záľudností v tom ako časovače v tomto protokole fungujú.

Na nasledovnom obrázku je ukážka z našich prezentácií, na ktorom sú zhrnuté príklady fungovania časovačou v protokoloch RIP, OSPF a EIGRP.

ste si všimli, že EIGRP hold-down timer nie je používaný lokálne na smerovači, ale je spolu s hello paketom odoslaný k susedovi, a susedný smerovač bude vami nastavený hold-down timer používať na Vás!

Toto fungovanie, akokoľvek užitočné, malo v starších verziách IOS systému problém, že ste pomocou show príkazov nemali možnosť poriadne zistiť hodnoty hello a hold-down časovačov nastavených na rozhraniach.

Jediné čo sa dalo zistiť bol hello časovač pomocou príkazu “show ip eigrp interface detail”. Ukážku môžete vidieť na nasledovnom obrázku.

novšom však nájdeme tento príkaz dostatočne obohatený a môžeme tak vďaka tomuto príkazu zistiť aj hold-down timer.

Na predošlom obrázku si všimnite nastavovanie týchto časovačov pre každé rozhranie samostatne.

PS: Pre vaše potreby príkazy na nastavenie týchto časovačov sú “ip hello-interval eigrp 1 25” a “ip hold-time eigrp 1 100”. Tieto príkazy nastanie pre EIGRP v AS “1” časovače hello na 25 sekúnd a hold-down na 100 sekúnd.

Preto ak na teste CCNA2 dostanete EIGRP zadanie a nieto po Vás bude chcieť overiť EIGRP hodnoty časovačov, ak Vám spomenutý “show” príkaz nedá hodnotu hold-down časovača, musíte sa upokojiť bude s prehľadaním “show running-config”.

Druhá možnosť je pozerať meniace sa hodnoty na susednom smerovači v “show ip eigrp neighbour”  až dokiaľ sa hodnota hold-down suseda neinkrementuje na novú hold-down hodnotu. Ukážku si môžete pozrieť na nasledovnom obrázku.

Ďakujem Vám za pozornosť a dúfam, že ste si takto so mnou mohli zhrnúť problematiku hľadania hodnôt časovačov v EIGRP.

S pozdravom

Peter Havrila, CCNP, Inštruktor RCNA FIIT STU

Skryté príkazy IOS

január 5, 2011 by

„A keď si dáte otáznik, tak sa vám zobrazia všetky commandy, ktoré môžete vyťukať.“ Nehovoril vám toto váš inštruktor náhodou? Ak áno, tak klamal 🙂 IOS má aj takzvané skryté príkazy, tie po zadaní otáznička nevidíte, ani nie sú doplnené tabulátorom, ale sú tam. Sedia v útrobách IOS a čakajú. Sú to väčšinou príkazy, ktoré sú v štádiu testovania a niekedy v budúcej verzii budú zverejnené, alebo sú to príkazy, ktoré by mali ostať schované pred zvedavými očami, alebo sú to tak trocha deštrukčné príkazy. Tak poďme ničiť routre.

Prvý skrytý príkaz, čo mi udrel do okuliarov, je test crash. Príkaz má otestovať správanie sa routra po padnutí tým, že ho zhodí. Najskôr treba zadať príkaz:

Router# test crash

Vybehne nám hláška, ktorá nás upozorňuje, že router crashne. Treba ťuknúť klávesu „C“ (musí to byť veľké C), enter a následne si môžeme vybrať pád. Router by sa mal sám reštartnúť a ak nie, tak mu treba dopomôcť. Príkaz je však užitočný pri testovaní správania sa pri rôznych chybách IOS.

Ďalší zaujímavý príkaz sa používa v IP telefónii. Príkaz

Router# csim start <number>

emuluje telefónny hovor. Príkaz je vhodný, ak nemáte fyzický prístup k telefónom, alebo ste až moc leniví sa poprechádzať. Pokiaľ vytáčame existujúce číslo, spojenie sa naozaj uskutoční a telefón zvoní. Príkaz je jeden zo základných testovacích príkazov pri testovaní spojenia.

Desiatky ďalších skrytých príkazov možno nájsť napríklad aj na tejto stránke http://www.elemental.net/~lf/undoc/
Mnohé z týchto príkazov dnes už nájdete ako štandardné príkazy IOS. Väčšina príkazov je však z kategórie show a debug. Spomeniem ešte jeden veľmi zaujímavý príkaz a to:

Router# test transmit

Pozrite si ho a eventuálne si ho skúste na cviku. Vygeneruje paket na želanie a otestuje tak spojenie.

Teraz tak rozmýšľam, neotvoril som Pandorinu skrinku? Už to vidím ako nám budete na najbližšom stretku zhadzovať routre. O niektorých ozaj deštrukčných príkazoch som však radšej pomlčal…

Filip Burda

Distance-Vector spravanie v OSPF?

január 2, 2011 by

Väčšinu z Vás na našich kurzoch CCNA učíme o OSPF ako o link-state protokole, ktorý je založený na Dijkstrovom algoritme. Ako už väčšina z Vás po druhom semestri CCNA vie, na rozdiel od protokolov ako je RIP a EIGRP, protokol OSPF pozná celú topológiu a tak sa vie vyhnúť problémom s topologickými slučkami. V tomto článku Vám túto predstavu naštrbím.

Táto predstava, ktorá je v rámci CCNA vyučovaná je uplne správna a na certifikciu ju máte vedieť presne tak, ako Vás ju na OSPF prednáškach učime. Ale svet je troška vačší ako CCNA.

Menej ľudí vie, že protokol OSPF má aj svoju “distance-vector” tvár, ktorú na CCNA nespoznáte (na CCNP sa už s Oblasťami v OSPF stretnete v plnej miere, ale tieto pravidlá sa tam len nechaju “tušiť” a nie su súčastou učiva vyžadovaného na certifikácií).

Tento distance-vector charakter OSPF sa prejavuje keď začneme s OSPF riešiť väčšie siete, ktoré využívaju viacero OSPF oblastí (OSPF Area). Podstata celého problému je, že OSPF je link-state využívajúci Dijkstrov algoritmus iba v rámci jednej oblasti.

To znamená, že topologicky strom sa vypočítava len pre jednu oblast a jeho “vetvy” nesiahaju do iných oblastí. Z tohto dovodu ak máme medzi oblastami viacero hraničných smerovačov (ABR – Area Boarder Router), tak OSPF sa znova vracia “iba” k fungovaniu na úrovni distance-vector protokolom a je tu náchylnosť na smerovacie slučky.

Poďme pekne poporiadku…

Čo CCNA ľudia ešte len tušia a CCNP ludia uz vedia je, že OSPF si vymiena informácie pomocou vytvárania susedstva a následne pomocou takzvaných LSA (Link-State Advertisement) paketov. Týchto LSA-čok má OSPF viacero druhov (každý identifikovaný číslom), z ktorých by som rád spomenul iba nasledovné:

  1. Router LSA (informácie o pritomnosti smerovača v oblasti)
  2. Network LSA (informácie o prefixe alebo podsieti v oblasti)
  3. Inter-Area network summary LSA (informácie o prefixe mimo oblasti v ktorej sa tento LSA typ vyskytuje)

Teraz k tomu ako sa tieto LSA šíria. V rámci jedneho SPF (shortest path first) stromu, ktorý je výsledkom Dijkstrovho algoritmu, sa berú do úvahy iba LSA typu 1 a 2 (vetu nebrať doslovne, tiež nie je celou pravdou ale to je mimo tohto článku). Teda iba tie o smerovačoch a sieťach v jednej oblasti. LSA typu 3 však vznikajú inak.

LSA typu 3 generujú ABR smerovače keď chcú preniesť informáciu o prefixe alebo sumarizovanom prefixe z jednej oblasti do inej.

Pre lepšiu názornosť prejdime k diagramu:

Ak by sme ostali iba pri logike OSPF vyučovanej na CCNA úrovni, záplava LSA paketov by mohla sposobit slučku nakoľko R1,R3 a R4 by nevedeli pri vytváraní LSA typu 3 rozlíšiť, kde v sieti sa reálne prefixy a iných oblastí nachádzaju. Napríklad sieť 5.100.5.0/24 by mohla byť šírená ako LSA 2 v rámci Area 2. Potom by však smerovače R3 a R4 tento LSA prevzali, vygenerovali by pre tento prefix LSA typu 3 a preposlali do oblastí Area 1 a Area 0. Problém by však mohol nastat, ak by R1 ako ďaľší ABR smerovač tieto LSA typu 3 preposlal tiež medzi  oblastami 1 a 0. Nakoľko R1 vo svojom Dijkstrovom SPF strome nevie presne povedať, kde sa reálne táto cielová sieť nachádza, tak pre tuto sieť z Area 2 nevie smerovač R1 fungovať inak ako na distance-vector princípoch.

Takže ako OSPF pre ABS smerovačoch postupuje? Má na to tri pravidlá:

  1. ABR sa pokladá za ABR ak aspon jedno jeho rozhranie je v Area 0 a toto rozhranie nie je v stave DOWN. Ak je táto podmienka splnená tak uz vo svojich LSA typu 1 nastavuje príznak “B” (Border) a v rámci oblasti tým oznamuje ze je ABR smerovačom.
  2. Ak má ABR v Area 0 vytvorené aspoň jedno susedstvo v stave FULL, tak ABR očakáva LSA typu 3 LEN z Area 0 a ignoruje LSA typu 3 z iných oblastí!
  3. ABR akceptuje a použíje na smerovanie LSA typu 3 naučené z iných oblastí ako Area 0 len v prípade ak NEMA v Area 0 vytvorené žiadne susedstvo. Len v tomto prípade je prijatie týchto LSA typu 3 bezpečné.

Pre náš diagram siete to znamená, že prefix 5.100.5.0/24 sa bude šíriť ako LSA typu 2 v rámci Area 2. Smerovač R4 generuje LSA typu 3 pre tento prefix pre Area 0 (platí prve pravidlo). Smerovač R3 sám seba nepovažuje za ABR aj ked je v dvoch oblastiach a preto nevygeneruje LSA typu 3 pre náš prefix.

Na druhej strane smerovač R3 prijme a použije LSA typu 3, ktoré dostane z R1. Logicky sa tento smerovač dá považovať za smerovač vo vnútri dvoch oblastí, ale nie hraničný.

Trik na záver

Ako teraz vieme, siete 5.100.5.0/24 a 5.100.2.0/24 na smerovačoch R2 a R5 budú komunikovať cez Area 0. To znamena, že dáta prejdu trasu R5=R4=R6=R1=R2 a nevyužiju možnú skratku R5=R3=R2.

Ak by sme chceli túto srkatku využiť dá sa na Cisco smerovačoch urobiť trik, že vytvoríme LoopBack rozhranie, ktore v nastaveniach ospf priradíme do Area 0. Takto splníme prvu podmienku ABR smerovača a smerovač R3 začne generovat LSA typu 3 pre siete z oblastí 1 a 2.

Krasa tohto riešenie je v tom, že aj ked takto “okabátime” OSPF na R3, nevznikne nám smerovacia slučka nakolko smerovače R1 a R4 odignorujú LSA typu 3 od smerovača R3 koli pravudlu 2 (nakoľko R1 a R4 maju v Area 0 vytovrené sesedstvo v stave FULL)

Týmto sa lúčim a teším sa na Vaše komentáre, postrehy alebo na naše osobné stretnutie na niektorom z kurzov.

Domáca úloha

Smerovanie sa dá ešte upraviť pomocou vytvorenia OSPF virtuálnich liniek (virtual link) medzi R3 a R1 alebo R3 a R4. Skúste si, keď už nie v nejakom simulatore ako je GNS3, tak aspoň pomocou aplikovania spomenutých pravidiel na papiery povedať, ako budu potom smerované dáta medzi sieťami na R2 a R5.

Odpoveď sa doszviete onedlho v ďaľšom článku alebo v diskusii pod týmto článkom.

S pozdravom

Peter Havrila, CCNP

Instruktor RCNA FIIT STU

Telefónne číslo

november 18, 2010 by

„Telefónne číslo je reťazec dekadických číslic, ktoré jednoznačne identifikujú koncový bod verejnej telefónnej siete.“, tvrdí Wikipedia v tomto odkaze. Vieme však skutočne ako sú telefónne čísla na Slovensku rozdelené?

Začnime s miestnymi volaniami. To sú volania v rámci primárnej oblasti (PO), kvázi okresy, len ich je menej. Na Slovensku ich máme 25. Vyššia úroveň hierarchie je sekundárna oblasť (SO) a tie sú 4. Každá PO má pridelený svoj kód, pričom celková dĺžka telefónneho čísla v našej krajine musí byť jednotná a to 9 číslic. Každá PO má dvojciferný rozlišovací kód okrem Bratislavy, ktorá ho má jednociferný. Preto ak voláte v rámci Bratislavskej PO, tak vytáčate 8-miestne číslo. V iných oblastiach vytáčate len 7-miestne číslo.

Ak chcete uskutočniť národne volanie (tzv. medzimestské, tiež long distance), tak musíte pred číslo koncovej stanice zadať aj kód PO. Bratislava má kód 2 a napríklad Košice majú kód 55. No a to je spomínaných 9 číslic. A samozrejme, aby ústredňa vedela, že ide o národne volanie, tak treba zadať pred PO kód ešte aj číslicu 0, informáciu, že ide o národné číslo. Kódy PO začínajú číslicami 2, 3, 4 alebo 5. Dajme si príklad. Chcem zavolať z Blavy do Košíc na číslo 1234567, tak vyťukám 0 55 1234567. Viac o predvoľbách nájdete tu.

Medzinárodne volania sa uskutočňujú tak, že pred číslo koncovej stanice sa dá kód primárnej oblasti a ešte pred tým národný kód a ešte predtým nejaká sekvencia, ktorá oznámi ústredni, že ide o medzinárodne volanie. Na Slovensku je to kód 00. Náš národný kód je 421. Ak chceme volať vedľa do českej republiky, tak použijeme ich národný kód 420. Ďalej použijeme kód PO a číslo koncovej stanice. Medzi národný kód a PO nedávame 0, teda informáciu, že ide o národné volanie. Celková dĺžka telefónneho čísla je však premenlivá, keďže už samotný národný rozlišovací kód je jedno- až trojciferný.

Častá otázka je, prečo sa používa pri telefónnych číslach znak +. Nuž, slovenská ústredňa reaguje na sekvenciu 00 ako pokus o medzinárodne volanie. Nie všade vo svete je to rovnako. Znak + teda nahrádza túto sekvenciu a podľa toho, v ktorej krajine práve ste, sa znak + „rozvinie“ a premení na konkrétny kód. Napr. USA používajú sekvenciu 011, Bielorusko používa 8, pauza, 10 a Brazília má hneď niekoľko exit kódov v závislosti od operátora. Takže do mobilu si zadávajte telefónne čísla v tvare + <tel. číslo>. Ak by som mal telefón v BA s číslom 12345678, tak moje číslo by bolo +421 2 12345678.

No a keď už spomínam mobily, ako je to s nimi? Easy. Číslo operátora má pevnú dĺžku 4 číslice, resp. 3 číslice a pred nimi 0 ako príznak národného volania a nasleduje 6-miestne telefónne číslo. Na Slovensku sú to čísla v rozsahu 0901 xxxxxx až 0909 xxxxxx, 091x xxxxxx, 094x xxxxxx a 095x xxxxxx.

Telefónne čísla s predvoľbou 0800 xxxxxx sú volania zadarmo, čiže na účet volaného (freephone). Avšak pozor na čísla 0806 xxxxxx až 0809 xxxxxx, 0900 xxxxxx, 097x xxxxxx až 098x xxxxxx. Tieto čísla sú so zvýšenou tarifou (premium rate services) a často krát sa zamieňajú s mobilnými číslami, alebo s volaniami na účet volaného.

Skrátené telefónne čísla, verejné služby a rôzne iné prkotinky sú troj- až päťmiestne telefónne čísla začínajúce číslicou 1. Najznámejšie sú 112, 150, 155, 158, 159, čísla taxíkov a tak podobne.

Samozrejme, že nájdeme aj mnohé iné služby so svojimi číselnými rozsahmi, no nad nimi sa už nebudem rozplývať.

Tieto informácie som si ukradol z prezentácie Dial Plan in Slovakia z kurzu IP Telephony. Samozrejme, že ide len o skrátenú verziu. Na tomto kurze sa naučíme nielen slovenský číslovací plán, ale si ho aj nakonfigurujeme na Cisco routroch. Okrem iného si predstavíme národný číslovací plán v USA a vo Veľkej Británii. Kto má záujem, môže sa prihlásiť 🙂

Filip Burda


%d bloggers like this: